DeliverHealth Ticketing System Degraded Performance | January 26
Incident
2026-01-26T23:18:00.0000000Z
DeliverHealth Ticketing System Degraded Performance | January 26
Status: Closed
Start:
2026-01-26T19:10:00.0000000Z
End:
2026-01-26T23:18:00.0000000Z
Duration: 4 hours 8 minutes
Affected Components:
Support Services
Ticketing System
Investigating
2026-01-26T19:10:00.0000000Z
2026-01-26T19:10:00.0000000Z
Please be advised that we are currently experiencing degraded performance with our ticketing system. Due to this, tickets may be delayed in creation as well as processing by our team.
For urgent assistance, please call our helpdesk at 800-858-0080.
Resolved
2026-01-26T23:18:00.0000000Z
2026-01-26T23:18:00.0000000Z
Please be advised that our ticketing system is back to normal operations, at this time.